Tuesday, September 15, 2015

This entry is kind of like a pastebin.  I recently managed to successfully install Cockatrice on my machine.  This is a lot more elaborate than your standard Windows install as it requires building it from source.  

So I have written down the method that just worked in the hopes that I won't have to re-guess it next time.

Note:  See the date-time of this post.  This worked on my system at this time.  This may not work years into the future as it often happens that different bits and pieces of different Linux distributions get updated (or not) in different ways.

Also, I haven't done a lot of these.  Use at your own risk.


Mon 14 Sep 2015 11:49:38 PM CDT ------------
On Ubuntu 14.04 LTS, these are the packages that you have to have installed before you can build cockatrice *including* servatrice:

sudo apt-get install build-essential g++ qtmobility-dev libprotobuf-dev protobuf-compiler libqt4-dev libgcrypt11-dev

You probably need this repository added:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && apt-get update

You want to be able to build with the cmake-gui  so you need the 'cmake' package and then probably also the package 'cmake-qt-gui' if installing the first package does not automatically install the gui.

sudo apt-get install cmake cmake-qt-gui

You also need Qt5.  To get it, you have to search for an offline installer (b/c the Online installer is rubbish) here:


After d/l-ing the file, chmod u+x and run it because the Qt people seem to think this is Windows.  Whatever, it makes no real difference.  You wind up with a folder in your home folder with the necessary code to compile/link against.  (You will need to know if your OS is 32 or 64 bit.  But you should know that, really.)

You might also need the package

sudo apt-get install libqt5sql5-mysql

The install directions say you need that to run servatrice with a database. Don't know what that means yet.

For sound to work, you also need

sudo apt-get install libqt5multimedia5 libqt5multimedia5-plugins

I don't care about sound right now, so I have not bothered with it.


d/l the cockatrice source from the button on the right side of this page


extract it to a folder, then cd into it in terminal

mkdir build

cd build

cmake-gui &

Then, in the gui, click Generate.

Then, for the Qt5Widgets_DIR setting, specify the path to the Qt5 stuff you previously downloaded via the offline installer.  And click to put a checkmark  in the box for WITH_SERVER setting, then click generate again and  cross your fingers.

If no errors, then in the terminal cd into the build directory and


and cross fingers.

if success, then 

sudo make install 

and you're golden.

You should now have the new commands:  cockatrice, oracle, and servatrice.

oracle is what you run to build your local card database .xml file (no pics yet, wait for the next part)

cockatrice is where you build a deck, and the actual game client itself.  Card artwork is downloaded on an as-needed basis.

servatrice is what you'll need to run in order to host a LAN game.

Furry cows moo and decompress.

No comments:

Post a Comment